I have a GUI

So following my post earlier today I now have a working xorg.conf and KDE 4.8.3 is running smoothly. Turns out there is an easy to use utility called nvidia-xconfig which I had overlooked and did the job perfectly. Also importantly I now have Chromium (Chrome for Linux if you didn't know) installed :) Time to start tinkering!

I've provided my xorg.conf here in-case it is useful to anyone. This works with a Nvidia GTS 450 linked by HDMI to a Panasonic 42" TX-P42U30B Plasma TV:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig

# nvidia-xconfig: version 295.71 (buildmeister@swio-display-x86-rhel47-04.nvidia.com) Thu Aug 2 20:28:32 PDT 2012

Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" 0 0 InputDevice "Mouse0" "CorePointer" InputDevice "Keyboard0" "CoreKeyboard" EndSection

Section "Module" Load "glx" EndSection

Section "InputDevice" # generated from data in "/etc/conf.d/gpm" Identifier "Mouse0" Driver "mouse" Option "Protocol" Option "Device" "/dev/input/mice" Option "Emulate3Buttons" "no" Option "ZAxisMapping" "4 5" EndSection

Section "InputDevice" Identifier "Keyboard0" Driver "kbd" EndSection

Section "Modes" Identifier "Modes0" ModeLine "1920x1080@60" 182.28 1920 1952 2640 2672 1080 1102 1113 1135 EndSection

Section "Monitor" Identifier "Monitor0" VendorName "Unkown" ModelName "Unknown" UseModes "Modes0" HorizSync 28.0 - 33.0 VertRefresh 43.0 - 72.0 EndSection

Section "Device" Identifier "GTS450" Driver "nvidia" VendorName "NVIDIA Corporation" EndSection Section "Screen" Identifier "Screen0" Device "GTS450" Monitor "Monitor0" DefaultDepth 24 Option "ConnectedMonitor" "DEP-0" Option "DPMS" "false" SubSection "Display" Depth 24 EndSubSection EndSection

Tom out!